Google: Imports an event This operation is used to add a private copy of an existing event to a calendar Only events with an event Type of default may be imported Deprecated behavior: If a non-default event is imported, its type will be changed to default and any event-type-specific properties it may have will be dropped — request body — body
Imports an event. This operation is used to add a private copy of an existing event to a calendar. Only events with an eventType of default may be imported. Deprecated behavior: If a non-default event is imported, its type will be changed to default and any event-type-specific properties it may have will be dropped.: request body, field body. Complete fields and constraints for contract 2026-10-27.
API reference · Contract 2026-10-27
SDK schema: Imports an event. This operation is used to add a private copy of an existing event to a calendar. Only events with an eventType of default may be imported. Deprecated behavior: If a non-default event is imported, its type will be changed to default and any event-type-specific properties it may have will be dropped — request body — body
| Field | Type | Presence | Description and constraints |
|---|---|---|---|
$ | object | Root | |
anyoneCanAddSelf | boolean | Optional | Whether anyone can invite themselves to the event (deprecated). Optional. The default is False. Default: false |
attachments | array | Optional | File attachments for the event. In order to modify attachments the supportsAttachments request parameter should be set to true. There can be at most 25 attachments per event, |
attachments[] | Model | Each item | Expand Creates an event — response body — attachments item |
attendees | array | Optional | The attendees of the event. See the Events with attendees guide for more information on scheduling events with other calendar users. Service accounts need to use domain-wide delegation of authority to populate the attendee list. |
attendees[] | Model | Each item | Expand Creates an event — request body — body attendees item |
attendeesOmitted | boolean | Optional | Whether attendees may have been omitted from the event’s representation. When retrieving an event, this may be due to a restriction specified by the maxAttendee query parameter. When updating an event, this can be used to only update the participant’s response. Optional. The default is False. Default: false |
birthdayProperties | Model | Optional | Expand Creates an event — response body — birthday Properties Birthday or special event data. Used if eventType is “birthday”. Immutable. |
colorId | string | Optional | The color of the event. This is an ID referring to an entry in the event section of the colors definition (see the colors endpoint). Optional. |
conferenceData | Model | Optional | Expand Creates an event — response body — conference Data The conference-related information, such as details of a Google Meet conference. To create new conference details use the createRequest field. To persist your changes, remember to set the conferenceDataVersion request parameter to 1 for all event modification requests. Warning: Reusing Google Meet conference data across different events can cause access issues and expose meeting details to unintended users. To help ensure meeting privacy, always generate a unique conference for each event by using the createRequest field. |
created | string | Optional | Creation time of the event (as a RFC3339 timestamp). Read-only. Format: date-time |
creator | Model | Optional | Expand Creates an event — response body — creator |
description | string | Optional | Description of the event. Can contain HTML. Optional. |
end | Model | Required within parent | Expand Creates an event — response body — end The (exclusive) end time of the event. For a recurring event, this is the end time of the first instance. |
endTimeUnspecified | boolean | Optional | Whether the end time is actually unspecified. An end time is still provided for compatibility reasons, even if this attribute is set to True. The default is False. Default: false |
etag | string | Optional | ETag of the resource. |
eventLabelId | string | Optional | The ID of the event label assigned to the event. Optional. This refers to the ID of an entry in the labelProperties.eventLabels property of the calendar (see the Calendars.get endpoint.) This property supersedes the index-based colorId property. To set or change this property, you need to specify eventLabelVersion=1 in the parameters of the insert, import, update, and patch methods. Setting an empty string, or not setting this field at all, will remove the existing label from the event. |
eventType | string | Optional | Specific type of the event. This cannot be modified after the event is created. Possible values are: - “birthday” - A special all-day event with an annual recurrence. - “default” - A regular event or not further specified. - “focusTime” - A focus-time event. - “fromGmail” - An event from Gmail. This type of event cannot be created. - “outOfOffice” - An out-of-office event. - “workingLocation” - A working location event. Default: default |
extendedProperties | Model | Optional | Expand Creates an event — response body — extended Properties |
focusTimeProperties | Model | Optional | Expand Creates an event — response body — focus Time Properties Focus Time event data. Used if eventType is focusTime. |
gadget | Model | Optional | Expand Creates an event — request body — body gadget |
guestsCanInviteOthers | boolean | Optional | Whether attendees other than the organizer can invite others to the event. Optional. The default is True. Default: true |
guestsCanModify | boolean | Optional | Whether attendees other than the organizer can modify the event. Optional. The default is False. Default: false |
guestsCanSeeOtherGuests | boolean | Optional | Whether attendees other than the organizer can see who the event’s attendees are. Optional. The default is True. Default: true |
hangoutLink | string | Optional | An absolute link to the Google Hangout associated with this event. Read-only. |
htmlLink | string | Optional | An absolute link to this event in the Google Calendar Web UI. Read-only. |
iCalUID | string | Required within parent | Event unique identifier as defined in RFC5545. It is used to uniquely identify events accross calendaring systems and must be supplied when importing events via the import method. Note that the iCalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same iCalUIDs. To retrieve an event using its iCalUID, call the events.list method using the iCalUID parameter. To retrieve an event using its id, call the events.get method. |
id | string | Optional | Opaque identifier of the event. When creating new single or recurring events, you can specify their IDs. Provided IDs must follow these rules: - characters allowed in the ID are those used in base32hex encoding, i.e. lowercase letters a-v and digits 0-9, see section 3.1.2 in RFC2938 - the length of the ID must be between 5 and 1024 characters - the ID must be unique per calendar Due to the globally distributed nature of the system, we cannot guarantee that ID collisions will be detected at event creation time. To minimize the risk of collisions we recommend using an established UUID algorithm such as one described in RFC4122. If you do not specify an ID, it will be automatically generated by the server. Note that the icalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same icalUIDs. |
kind | string | Optional | Type of the resource (“calendar#event”). Default: calendar#event |
location | string | Optional | Geographic location of the event as free-form text. Optional. |
locked | boolean | Optional | Whether this is a locked event copy where no changes can be made to the main event fields “summary”, “description”, “location”, “start”, “end” or “recurrence”. The default is False. Read-Only. Default: false |
organizer | Model | Optional | Expand Creates an event — response body — organizer |
originalStartTime | Model | Optional | Expand Creates an event — response body — end For an instance of a recurring event, this is the time at which this event would start according to the recurrence data in the recurring event identified by recurringEventId. It uniquely identifies the instance within the recurring event series even if the instance was moved to a different time. Immutable. |
outOfOfficeProperties | Model | Optional | Expand Creates an event — response body — out Of Office Properties Out of office event data. Used if eventType is outOfOffice. |
privateCopy | boolean | Optional | If set to True, Event propagation is disabled. Note that it is not the same thing as Private event properties. Optional. Immutable. The default is False. Default: false |
recurrence | array | Optional | List of RRULE, EXRULE, RDATE and EXDATE lines for a recurring event, as specified in RFC5545. Note that DTSTART and DTEND lines are not allowed in this field; event start and end times are specified in the start and end fields. This field is omitted for single events or instances of recurring events. |
recurrence[] | string | Each item | |
recurringEventId | string | Optional | For an instance of a recurring event, this is the id of the recurring event to which this instance belongs. Immutable. |
reminders | Model | Optional | Expand Creates an event — request body — body reminders |
sequence | integer | Optional | Sequence number as per iCalendar. Format: int32 |
source | object | Optional | Source from which the event was created. For example, a web page, an email message or any document identifiable by an URL with HTTP or HTTPS scheme. Can only be seen or modified by the creator of the event. |
source.title | string | Optional | Title of the source; for example a title of a web page or an email subject. |
source.url | string | Optional | URL of the source pointing to a resource. The URL scheme must be HTTP or HTTPS. |
start | Model | Required within parent | Expand Creates an event — response body — end The (inclusive) start time of the event. For a recurring event, this is the start time of the first instance. |
status | string | Optional | Status of the event. Optional. Possible values are: - “confirmed” - The event is confirmed. This is the default status. - “tentative” - The event is tentatively confirmed. - “cancelled” - The event is cancelled (deleted). The list method returns cancelled events only on incremental sync (when syncToken or updatedMin are specified) or if the showDeleted flag is set to true. The get method always returns them. A cancelled status represents two different states depending on the event type: - Cancelled exceptions of an uncancelled recurring event indicate that this instance should no longer be presented to the user. Clients should store these events for the lifetime of the parent recurring event. Cancelled exceptions are only guaranteed to have values for the id, recurringEventId and originalStartTime fields populated. The other fields might be empty. - All other cancelled events represent deleted events. Clients should remove their locally synced copies. Such cancelled events will eventually disappear, so do not rely on them being available indefinitely. Deleted events are only guaranteed to have the id field populated. On the organizer’s calendar, cancelled events continue to expose event details (summary, location, etc.) so that they can be restored (undeleted). Similarly, the events to which the user was invited and that they manually removed continue to provide details. However, incremental sync requests with showDeleted set to false will not return these details. If an event changes its organizer (for example via the move operation) and the original organizer is not on the attendee list, it will leave behind a cancelled event where only the id field is guaranteed to be populated. |
summary | string | Optional | Title of the event. |
transparency | string | Optional | Whether the event blocks time on the calendar. Optional. Possible values are: - “opaque” - Default value. The event does block time on the calendar. This is equivalent to setting Show me as to Busy in the Calendar UI. - “transparent” - The event does not block time on the calendar. This is equivalent to setting Show me as to Available in the Calendar UI. Default: opaque |
updated | string | Optional | Last modification time of the main event data (as a RFC3339 timestamp). Updating event reminders will not cause this to change. Read-only. Format: date-time |
visibility | string | Optional | Visibility of the event. Optional. Possible values are: - “default” - Uses the default visibility for events on the calendar. This is the default value. - “public” - The event is public and event details are visible to all readers of the calendar. - “private” - The event is private and only event attendees may view event details. - “confidential” - The event is private. This value is provided for compatibility reasons. Note on recurring events: Changing the visibility of a single instance of a recurring event can affect all instances of the series. If the new setting is more restrictive (e.g. from public to private), it is applied to all instances. If the new setting is less restrictive (e.g. from private to public), the change is ignored. To make a recurring event less restrictive, you must update the parent recurring event. Default: default |
workingLocationProperties | Model | Optional | Expand Creates an event — response body — working Location Properties Working location event data. |
Referenced models: Creates an event — response body — conference Data, Creates an event — response body — attachments item, Creates an event — response body — birthday Properties, Creates an event — response body — end, Creates an event — response body — focus Time Properties, Creates an event — response body — out Of Office Properties, Creates an event — response body — working Location Properties, Creates an event — request body — body attendees item, Creates an event — response body — creator, Creates an event — response body — extended Properties, Creates an event — request body — body gadget, Creates an event — response body — organizer, Creates an event — request body — body reminders