Skip to content

Google: Calendar events schemas

29 Google schemas with complete fields and constraints.

← Calendar events operations · All schemas

Creates an event — request body — body

FieldTypePresenceDescription and constraints
$objectRoot
anyoneCanAddSelfbooleanOptionalWhether anyone can invite themselves to the event (deprecated). Optional. The default is False.
Default: false
attachmentsarrayOptionalFile attachments for the event.
In order to modify attachments the supportsAttachments request parameter should be set to true.
There can be at most 25 attachments per event,
attachments[]ModelEach itemExpand Creates an event — response body — attachments item
attendeesarrayOptionalThe attendees of the event. See the Events with attendees guide for more information on scheduling events with other calendar users. Service accounts need to use domain-wide delegation of authority to populate the attendee list.
attendees[]ModelEach itemExpand Creates an event — request body — body attendees item
attendeesOmittedbooleanOptionalWhether attendees may have been omitted from the event's representation. When retrieving an event, this may be due to a restriction specified by the maxAttendee query parameter. When updating an event, this can be used to only update the participant's response. Optional. The default is False.
Default: false
birthdayPropertiesModelOptionalExpand Creates an event — response body — birthday Properties
Birthday or special event data. Used if eventType is "birthday". Immutable.
colorIdstringOptionalThe color of the event. This is an ID referring to an entry in the event section of the colors definition (see the colors endpoint). Optional.
conferenceDataModelOptionalExpand Creates an event — response body — conference Data
The conference-related information, such as details of a Google Meet conference. To create new conference details use the createRequest field. To persist your changes, remember to set the conferenceDataVersion request parameter to 1 for all event modification requests. Warning: Reusing Google Meet conference data across different events can cause access issues and expose meeting details to unintended users. To help ensure meeting privacy, always generate a unique conference for each event by using the createRequest field.
createdstringOptionalCreation time of the event (as a RFC3339 timestamp). Read-only.
Format: date-time
creatorModelOptionalExpand Creates an event — response body — creator
descriptionstringOptionalDescription of the event. Can contain HTML. Optional.
endModelRequired within parentExpand Creates an event — response body — end
The (exclusive) end time of the event. For a recurring event, this is the end time of the first instance.
endTimeUnspecifiedbooleanOptionalWhether the end time is actually unspecified. An end time is still provided for compatibility reasons, even if this attribute is set to True. The default is False.
Default: false
etagstringOptionalETag of the resource.
eventLabelIdstringOptionalThe ID of the event label assigned to the event. Optional. This refers to the ID of an entry in the labelProperties.eventLabels property of the calendar (see the Calendars.get endpoint.)
This property supersedes the index-based colorId property. To set or change this property, you need to specify eventLabelVersion=1 in the parameters of the insert, import, update, and patch methods.
Setting an empty string, or not setting this field at all, will remove the existing label from the event.
eventTypestringOptionalSpecific type of the event. This cannot be modified after the event is created. Possible values are:
- "birthday" - A special all-day event with an annual recurrence.
- "default" - A regular event or not further specified.
- "focusTime" - A focus-time event.
- "fromGmail" - An event from Gmail. This type of event cannot be created.
- "outOfOffice" - An out-of-office event.
- "workingLocation" - A working location event.
Default: default
extendedPropertiesModelOptionalExpand Creates an event — response body — extended Properties
focusTimePropertiesModelOptionalExpand Creates an event — response body — focus Time Properties
Focus Time event data. Used if eventType is focusTime.
gadgetModelOptionalExpand Creates an event — request body — body gadget
guestsCanInviteOthersbooleanOptionalWhether attendees other than the organizer can invite others to the event. Optional. The default is True.
Default: true
guestsCanModifybooleanOptionalWhether attendees other than the organizer can modify the event. Optional. The default is False.
Default: false
guestsCanSeeOtherGuestsbooleanOptionalWhether attendees other than the organizer can see who the event's attendees are. Optional. The default is True.
Default: true
hangoutLinkstringOptionalAn absolute link to the Google Hangout associated with this event. Read-only.
htmlLinkstringOptionalAn absolute link to this event in the Google Calendar Web UI. Read-only.
iCalUIDstringOptionalEvent unique identifier as defined in RFC5545. It is used to uniquely identify events accross calendaring systems and must be supplied when importing events via the import method.
Note that the iCalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same iCalUIDs. To retrieve an event using its iCalUID, call the events.list method using the iCalUID parameter. To retrieve an event using its id, call the events.get method.
idstringOptionalOpaque identifier of the event. When creating new single or recurring events, you can specify their IDs. Provided IDs must follow these rules:
- characters allowed in the ID are those used in base32hex encoding, i.e. lowercase letters a-v and digits 0-9, see section 3.1.2 in RFC2938
- the length of the ID must be between 5 and 1024 characters
- the ID must be unique per calendar Due to the globally distributed nature of the system, we cannot guarantee that ID collisions will be detected at event creation time. To minimize the risk of collisions we recommend using an established UUID algorithm such as one described in RFC4122.
If you do not specify an ID, it will be automatically generated by the server.
Note that the icalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same icalUIDs.
kindstringOptionalType of the resource ("calendar#event").
Default: calendar#event
locationstringOptionalGeographic location of the event as free-form text. Optional.
lockedbooleanOptionalWhether this is a locked event copy where no changes can be made to the main event fields "summary", "description", "location", "start", "end" or "recurrence". The default is False. Read-Only.
Default: false
organizerModelOptionalExpand Creates an event — response body — organizer
originalStartTimeModelOptionalExpand Creates an event — response body — end
For an instance of a recurring event, this is the time at which this event would start according to the recurrence data in the recurring event identified by recurringEventId. It uniquely identifies the instance within the recurring event series even if the instance was moved to a different time. Immutable.
outOfOfficePropertiesModelOptionalExpand Creates an event — response body — out Of Office Properties
Out of office event data. Used if eventType is outOfOffice.
privateCopybooleanOptionalIf set to True, Event propagation is disabled. Note that it is not the same thing as Private event properties. Optional. Immutable. The default is False.
Default: false
recurrencearrayOptionalList of RRULE, EXRULE, RDATE and EXDATE lines for a recurring event, as specified in RFC5545. Note that DTSTART and DTEND lines are not allowed in this field; event start and end times are specified in the start and end fields. This field is omitted for single events or instances of recurring events.
recurrence[]stringEach item
recurringEventIdstringOptionalFor an instance of a recurring event, this is the id of the recurring event to which this instance belongs. Immutable.
remindersModelOptionalExpand Creates an event — request body — body reminders
sequenceintegerOptionalSequence number as per iCalendar.
Format: int32
sourceobjectOptionalSource from which the event was created. For example, a web page, an email message or any document identifiable by an URL with HTTP or HTTPS scheme. Can only be seen or modified by the creator of the event.
source.titlestringOptionalTitle of the source; for example a title of a web page or an email subject.
source.urlstringOptionalURL of the source pointing to a resource. The URL scheme must be HTTP or HTTPS.
startModelRequired within parentExpand Creates an event — response body — end
The (inclusive) start time of the event. For a recurring event, this is the start time of the first instance.
statusstringOptionalStatus of the event. Optional. Possible values are:
- "confirmed" - The event is confirmed. This is the default status.
- "tentative" - The event is tentatively confirmed.
- "cancelled" - The event is cancelled (deleted). The list method returns cancelled events only on incremental sync (when syncToken or updatedMin are specified) or if the showDeleted flag is set to true. The get method always returns them.
A cancelled status represents two different states depending on the event type:
- Cancelled exceptions of an uncancelled recurring event indicate that this instance should no longer be presented to the user. Clients should store these events for the lifetime of the parent recurring event.
Cancelled exceptions are only guaranteed to have values for the id, recurringEventId and originalStartTime fields populated. The other fields might be empty.
- All other cancelled events represent deleted events. Clients should remove their locally synced copies. Such cancelled events will eventually disappear, so do not rely on them being available indefinitely.
Deleted events are only guaranteed to have the id field populated. On the organizer's calendar, cancelled events continue to expose event details (summary, location, etc.) so that they can be restored (undeleted). Similarly, the events to which the user was invited and that they manually removed continue to provide details. However, incremental sync requests with showDeleted set to false will not return these details.
If an event changes its organizer (for example via the move operation) and the original organizer is not on the attendee list, it will leave behind a cancelled event where only the id field is guaranteed to be populated.
summarystringOptionalTitle of the event.
transparencystringOptionalWhether the event blocks time on the calendar. Optional. Possible values are:
- "opaque" - Default value. The event does block time on the calendar. This is equivalent to setting Show me as to Busy in the Calendar UI.
- "transparent" - The event does not block time on the calendar. This is equivalent to setting Show me as to Available in the Calendar UI.
Default: opaque
updatedstringOptionalLast modification time of the main event data (as a RFC3339 timestamp). Updating event reminders will not cause this to change. Read-only.
Format: date-time
visibilitystringOptionalVisibility of the event. Optional. Possible values are:
- "default" - Uses the default visibility for events on the calendar. This is the default value.
- "public" - The event is public and event details are visible to all readers of the calendar.
- "private" - The event is private and only event attendees may view event details.
- "confidential" - The event is private. This value is provided for compatibility reasons.
Note on recurring events: Changing the visibility of a single instance of a recurring event can affect all instances of the series. If the new setting is more restrictive (e.g. from public to private), it is applied to all instances. If the new setting is less restrictive (e.g. from private to public), the change is ignored. To make a recurring event less restrictive, you must update the parent recurring event.
Default: default
workingLocationPropertiesModelOptionalExpand Creates an event — response body — working Location Properties
Working location event data.

Referenced models: Creates an event — response body — conference Data, Creates an event — response body — attachments item, Creates an event — response body — birthday Properties, Creates an event — response body — end, Creates an event — response body — focus Time Properties, Creates an event — response body — out Of Office Properties, Creates an event — response body — working Location Properties, Creates an event — request body — body attendees item, Creates an event — response body — creator, Creates an event — response body — extended Properties, Creates an event — request body — body gadget, Creates an event — response body — organizer, Creates an event — request body — body reminders

Creates an event — request body — body attendees item

FieldTypePresenceDescription and constraints
$objectRoot
additionalGuestsintegerOptionalNumber of additional guests. Optional. The default is 0.
Default: 0
Format: int32
asyncOperationstringOptionalIf present, indicates the status of an asynchronous operation ongoing for this attendee (e.g. listing of members of large attendee groups). Read-only. The default is to not be present.
Possible values are:
- "inProgress" - The asynchronous operation is in progress.
- (not present) - Otherwise.
Default:
commentstringOptionalThe attendee's response comment. Optional.
displayNamestringOptionalThe attendee's name, if available. Optional.
emailstringOptionalThe attendee's email address, if available. This field must be present when adding an attendee. It must be a valid email address as per RFC5322.
Required when adding an attendee.
idstringOptionalThe attendee's Profile ID, if available.
optionalbooleanOptionalWhether this is an optional attendee. Optional. The default is False.
Default: false
organizerbooleanOptionalWhether the attendee is the organizer of the event. Read-only. The default is False.
resourcebooleanOptionalWhether the attendee is a resource. Can only be set when the attendee is added to the event for the first time. Subsequent modifications are ignored. Optional. The default is False.
Default: false
responseStatusstringOptionalThe attendee's response status. Possible values are:
- "needsAction" - The attendee has not responded to the invitation (recommended for new events).
- "declined" - The attendee has declined the invitation.
- "tentative" - The attendee has tentatively accepted the invitation.
- "accepted" - The attendee has accepted the invitation. Warning: If you add an event using the values declined, tentative, or accepted, attendees with the "Add invitations to my calendar" setting set to "When I respond to invitation in email" or "Only if the sender is known" might have their response reset to needsAction and won't see an event in their calendar unless they change their response in the event invitation email. Furthermore, if more than 200 guests are invited to the event, response status is not propagated to the guests.
selfbooleanOptionalWhether this entry represents the calendar on which this copy of the event appears. Read-only. The default is False.
Default: false

Creates an event — request body — body gadget

FieldTypePresenceDescription and constraints
$objectRootA gadget that extends this event. Gadgets are deprecated; this structure is instead only used for returning birthday calendar metadata.
displaystringOptionalThe gadget's display mode. Deprecated. Possible values are:
- "icon" - The gadget displays next to the event's title in the calendar view.
- "chip" - The gadget displays when the event is clicked.
heightintegerOptionalThe gadget's height in pixels. The height must be an integer greater than 0. Optional. Deprecated.
Format: int32
iconLinkstringOptionalThe gadget's icon URL. The URL scheme must be HTTPS. Deprecated.
linkstringOptionalThe gadget's URL. The URL scheme must be HTTPS. Deprecated.
preferencesobjectOptionalPreferences.
Additional keys: see wildcard field
preferences.*stringAdditional keysThe preference name and corresponding value.
titlestringOptionalThe gadget's title. Deprecated.
typestringOptionalThe gadget's type. Deprecated.
widthintegerOptionalThe gadget's width in pixels. The width must be an integer greater than 0. Optional. Deprecated.
Format: int32

Creates an event — request body — body reminders

FieldTypePresenceDescription and constraints
$objectRootInformation about the event's reminders for the authenticated user. Note that changing reminders does not also change the updated property of the enclosing event.
overridesarrayOptionalIf the event doesn't use the default reminders, this lists the reminders specific to the event, or, if not set, indicates that no reminders are set for this event. The maximum number of override reminders is 5.
overrides[]ModelEach itemExpand Updates an existing calendar on the user's calendar list — request body — body default Reminders item
useDefaultbooleanOptionalWhether the default reminders of the calendar apply to the event.

Referenced models: Updates an existing calendar on the user's calendar list — request body — body default Reminders item

Creates an event — response body

FieldTypePresenceDescription and constraints
$objectRoot
anyoneCanAddSelfbooleanOptionalWhether anyone can invite themselves to the event (deprecated). Optional. The default is False.
Default: false
attachmentsarrayOptionalFile attachments for the event.
In order to modify attachments the supportsAttachments request parameter should be set to true.
There can be at most 25 attachments per event,
attachments[]ModelEach itemExpand Creates an event — response body — attachments item
attendeesarrayOptionalThe attendees of the event. See the Events with attendees guide for more information on scheduling events with other calendar users. Service accounts need to use domain-wide delegation of authority to populate the attendee list.
attendees[]ModelEach itemExpand Creates an event — response body — attendees item
attendeesOmittedbooleanOptionalWhether attendees may have been omitted from the event's representation. When retrieving an event, this may be due to a restriction specified by the maxAttendee query parameter. When updating an event, this can be used to only update the participant's response. Optional. The default is False.
Default: false
birthdayPropertiesModelOptionalExpand Creates an event — response body — birthday Properties
Birthday or special event data. Used if eventType is "birthday". Immutable.
colorIdstringOptionalThe color of the event. This is an ID referring to an entry in the event section of the colors definition (see the colors endpoint). Optional.
conferenceDataModelOptionalExpand Creates an event — response body — conference Data
The conference-related information, such as details of a Google Meet conference. To create new conference details use the createRequest field. To persist your changes, remember to set the conferenceDataVersion request parameter to 1 for all event modification requests. Warning: Reusing Google Meet conference data across different events can cause access issues and expose meeting details to unintended users. To help ensure meeting privacy, always generate a unique conference for each event by using the createRequest field.
createdstringOptionalCreation time of the event (as a RFC3339 timestamp). Read-only.
Format: date-time
creatorModelOptionalExpand Creates an event — response body — creator
descriptionstringOptionalDescription of the event. Can contain HTML. Optional.
endModelOptionalExpand Creates an event — response body — end
The (exclusive) end time of the event. For a recurring event, this is the end time of the first instance.
endTimeUnspecifiedbooleanOptionalWhether the end time is actually unspecified. An end time is still provided for compatibility reasons, even if this attribute is set to True. The default is False.
Default: false
etagstringOptionalETag of the resource.
eventLabelIdstringOptionalThe ID of the event label assigned to the event. Optional. This refers to the ID of an entry in the labelProperties.eventLabels property of the calendar (see the Calendars.get endpoint.)
This property supersedes the index-based colorId property. To set or change this property, you need to specify eventLabelVersion=1 in the parameters of the insert, import, update, and patch methods.
Setting an empty string, or not setting this field at all, will remove the existing label from the event.
eventTypestringOptionalSpecific type of the event. This cannot be modified after the event is created. Possible values are:
- "birthday" - A special all-day event with an annual recurrence.
- "default" - A regular event or not further specified.
- "focusTime" - A focus-time event.
- "fromGmail" - An event from Gmail. This type of event cannot be created.
- "outOfOffice" - An out-of-office event.
- "workingLocation" - A working location event.
Default: default
extendedPropertiesModelOptionalExpand Creates an event — response body — extended Properties
focusTimePropertiesModelOptionalExpand Creates an event — response body — focus Time Properties
Focus Time event data. Used if eventType is focusTime.
gadgetobjectOptionalA gadget that extends this event. Gadgets are deprecated; this structure is instead only used for returning birthday calendar metadata.
gadget.displaystringOptionalThe gadget's display mode. Deprecated. Possible values are:
- "icon" - The gadget displays next to the event's title in the calendar view.
- "chip" - The gadget displays when the event is clicked.
gadget.heightJSONOptional
gadget.height (anyOf 1)integerAlternativeThe gadget's height in pixels. The height must be an integer greater than 0. Optional. Deprecated.
Format: int32
gadget.height (anyOf 2)stringAlternativePattern: ^-?[0-9]+(?:\.[0-9]+)?(?:[eE][+-]?[0-9]+)?$
gadget.iconLinkstringOptionalThe gadget's icon URL. The URL scheme must be HTTPS. Deprecated.
gadget.linkstringOptionalThe gadget's URL. The URL scheme must be HTTPS. Deprecated.
gadget.preferencesobjectOptionalPreferences.
Additional keys: see wildcard field
gadget.preferences.*stringAdditional keysThe preference name and corresponding value.
gadget.titlestringOptionalThe gadget's title. Deprecated.
gadget.typestringOptionalThe gadget's type. Deprecated.
gadget.widthJSONOptional
gadget.width (anyOf 1)integerAlternativeThe gadget's width in pixels. The width must be an integer greater than 0. Optional. Deprecated.
Format: int32
gadget.width (anyOf 2)stringAlternativePattern: ^-?[0-9]+(?:\.[0-9]+)?(?:[eE][+-]?[0-9]+)?$
guestsCanInviteOthersbooleanOptionalWhether attendees other than the organizer can invite others to the event. Optional. The default is True.
Default: true
guestsCanModifybooleanOptionalWhether attendees other than the organizer can modify the event. Optional. The default is False.
Default: false
guestsCanSeeOtherGuestsbooleanOptionalWhether attendees other than the organizer can see who the event's attendees are. Optional. The default is True.
Default: true
hangoutLinkstringOptionalAn absolute link to the Google Hangout associated with this event. Read-only.
htmlLinkstringOptionalAn absolute link to this event in the Google Calendar Web UI. Read-only.
iCalUIDstringOptionalEvent unique identifier as defined in RFC5545. It is used to uniquely identify events accross calendaring systems and must be supplied when importing events via the import method.
Note that the iCalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same iCalUIDs. To retrieve an event using its iCalUID, call the events.list method using the iCalUID parameter. To retrieve an event using its id, call the events.get method.
idstringOptionalOpaque identifier of the event. When creating new single or recurring events, you can specify their IDs. Provided IDs must follow these rules:
- characters allowed in the ID are those used in base32hex encoding, i.e. lowercase letters a-v and digits 0-9, see section 3.1.2 in RFC2938
- the length of the ID must be between 5 and 1024 characters
- the ID must be unique per calendar Due to the globally distributed nature of the system, we cannot guarantee that ID collisions will be detected at event creation time. To minimize the risk of collisions we recommend using an established UUID algorithm such as one described in RFC4122.
If you do not specify an ID, it will be automatically generated by the server.
Note that the icalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same icalUIDs.
kindstringOptionalType of the resource ("calendar#event").
Default: calendar#event
locationstringOptionalGeographic location of the event as free-form text. Optional.
lockedbooleanOptionalWhether this is a locked event copy where no changes can be made to the main event fields "summary", "description", "location", "start", "end" or "recurrence". The default is False. Read-Only.
Default: false
organizerModelOptionalExpand Creates an event — response body — organizer
originalStartTimeModelOptionalExpand Creates an event — response body — end
For an instance of a recurring event, this is the time at which this event would start according to the recurrence data in the recurring event identified by recurringEventId. It uniquely identifies the instance within the recurring event series even if the instance was moved to a different time. Immutable.
outOfOfficePropertiesModelOptionalExpand Creates an event — response body — out Of Office Properties
Out of office event data. Used if eventType is outOfOffice.
privateCopybooleanOptionalIf set to True, Event propagation is disabled. Note that it is not the same thing as Private event properties. Optional. Immutable. The default is False.
Default: false
recurrencearrayOptionalList of RRULE, EXRULE, RDATE and EXDATE lines for a recurring event, as specified in RFC5545. Note that DTSTART and DTEND lines are not allowed in this field; event start and end times are specified in the start and end fields. This field is omitted for single events or instances of recurring events.
recurrence[]stringEach item
recurringEventIdstringOptionalFor an instance of a recurring event, this is the id of the recurring event to which this instance belongs. Immutable.
remindersobjectOptionalInformation about the event's reminders for the authenticated user. Note that changing reminders does not also change the updated property of the enclosing event.
reminders.overridesarrayOptionalIf the event doesn't use the default reminders, this lists the reminders specific to the event, or, if not set, indicates that no reminders are set for this event. The maximum number of override reminders is 5.
reminders.overrides[]ModelEach itemExpand Returns events on the specified calendar — response body — default Reminders item
reminders.useDefaultbooleanOptionalWhether the default reminders of the calendar apply to the event.
sequenceJSONOptional
sequence (anyOf 1)integerAlternativeSequence number as per iCalendar.
Format: int32
sequence (anyOf 2)stringAlternativePattern: ^-?[0-9]+(?:\.[0-9]+)?(?:[eE][+-]?[0-9]+)?$
sourceobjectOptionalSource from which the event was created. For example, a web page, an email message or any document identifiable by an URL with HTTP or HTTPS scheme. Can only be seen or modified by the creator of the event.
source.titlestringOptionalTitle of the source; for example a title of a web page or an email subject.
source.urlstringOptionalURL of the source pointing to a resource. The URL scheme must be HTTP or HTTPS.
startModelOptionalExpand Creates an event — response body — end
The (inclusive) start time of the event. For a recurring event, this is the start time of the first instance.
statusstringOptionalStatus of the event. Optional. Possible values are:
- "confirmed" - The event is confirmed. This is the default status.
- "tentative" - The event is tentatively confirmed.
- "cancelled" - The event is cancelled (deleted). The list method returns cancelled events only on incremental sync (when syncToken or updatedMin are specified) or if the showDeleted flag is set to true. The get method always returns them.
A cancelled status represents two different states depending on the event type:
- Cancelled exceptions of an uncancelled recurring event indicate that this instance should no longer be presented to the user. Clients should store these events for the lifetime of the parent recurring event.
Cancelled exceptions are only guaranteed to have values for the id, recurringEventId and originalStartTime fields populated. The other fields might be empty.
- All other cancelled events represent deleted events. Clients should remove their locally synced copies. Such cancelled events will eventually disappear, so do not rely on them being available indefinitely.
Deleted events are only guaranteed to have the id field populated. On the organizer's calendar, cancelled events continue to expose event details (summary, location, etc.) so that they can be restored (undeleted). Similarly, the events to which the user was invited and that they manually removed continue to provide details. However, incremental sync requests with showDeleted set to false will not return these details.
If an event changes its organizer (for example via the move operation) and the original organizer is not on the attendee list, it will leave behind a cancelled event where only the id field is guaranteed to be populated.
summarystringOptionalTitle of the event.
transparencystringOptionalWhether the event blocks time on the calendar. Optional. Possible values are:
- "opaque" - Default value. The event does block time on the calendar. This is equivalent to setting Show me as to Busy in the Calendar UI.
- "transparent" - The event does not block time on the calendar. This is equivalent to setting Show me as to Available in the Calendar UI.
Default: opaque
updatedstringOptionalLast modification time of the main event data (as a RFC3339 timestamp). Updating event reminders will not cause this to change. Read-only.
Format: date-time
visibilitystringOptionalVisibility of the event. Optional. Possible values are:
- "default" - Uses the default visibility for events on the calendar. This is the default value.
- "public" - The event is public and event details are visible to all readers of the calendar.
- "private" - The event is private and only event attendees may view event details.
- "confidential" - The event is private. This value is provided for compatibility reasons.
Note on recurring events: Changing the visibility of a single instance of a recurring event can affect all instances of the series. If the new setting is more restrictive (e.g. from public to private), it is applied to all instances. If the new setting is less restrictive (e.g. from private to public), the change is ignored. To make a recurring event less restrictive, you must update the parent recurring event.
Default: default
workingLocationPropertiesModelOptionalExpand Creates an event — response body — working Location Properties
Working location event data.

Referenced models: Creates an event — response body — conference Data, Creates an event — response body — attachments item, Creates an event — response body — attendees item, Creates an event — response body — birthday Properties, Creates an event — response body — end, Creates an event — response body — focus Time Properties, Creates an event — response body — out Of Office Properties, Returns events on the specified calendar — response body — default Reminders item, Creates an event — response body — working Location Properties, Creates an event — response body — creator, Creates an event — response body — extended Properties, Creates an event — response body — organizer

Creates an event — response body — attachments item

FieldTypePresenceDescription and constraints
$objectRoot
fileIdstringOptionalID of the attached file. Read-only.
For Google Drive files, this is the ID of the corresponding Files resource entry in the Drive API.
fileUrlstringOptionalURL link to the attachment.
For adding Google Drive file attachments use the same format as in alternateLink property of the Files resource in the Drive API.
Required when adding an attachment.
iconLinkstringOptionalURL link to the attachment's icon. This field can only be modified for custom third-party attachments.
mimeTypestringOptionalInternet media type (MIME type) of the attachment.
titlestringOptionalAttachment title.

Creates an event — response body — attendees item

FieldTypePresenceDescription and constraints
$objectRoot
additionalGuestsJSONOptional
additionalGuests (anyOf 1)integerAlternativeNumber of additional guests. Optional. The default is 0.
Default: 0
Format: int32
additionalGuests (anyOf 2)stringAlternativePattern: ^-?[0-9]+(?:\.[0-9]+)?(?:[eE][+-]?[0-9]+)?$
asyncOperationstringOptionalIf present, indicates the status of an asynchronous operation ongoing for this attendee (e.g. listing of members of large attendee groups). Read-only. The default is to not be present.
Possible values are:
- "inProgress" - The asynchronous operation is in progress.
- (not present) - Otherwise.
Default:
commentstringOptionalThe attendee's response comment. Optional.
displayNamestringOptionalThe attendee's name, if available. Optional.
emailstringOptionalThe attendee's email address, if available. This field must be present when adding an attendee. It must be a valid email address as per RFC5322.
Required when adding an attendee.
idstringOptionalThe attendee's Profile ID, if available.
optionalbooleanOptionalWhether this is an optional attendee. Optional. The default is False.
Default: false
organizerbooleanOptionalWhether the attendee is the organizer of the event. Read-only. The default is False.
resourcebooleanOptionalWhether the attendee is a resource. Can only be set when the attendee is added to the event for the first time. Subsequent modifications are ignored. Optional. The default is False.
Default: false
responseStatusstringOptionalThe attendee's response status. Possible values are:
- "needsAction" - The attendee has not responded to the invitation (recommended for new events).
- "declined" - The attendee has declined the invitation.
- "tentative" - The attendee has tentatively accepted the invitation.
- "accepted" - The attendee has accepted the invitation. Warning: If you add an event using the values declined, tentative, or accepted, attendees with the "Add invitations to my calendar" setting set to "When I respond to invitation in email" or "Only if the sender is known" might have their response reset to needsAction and won't see an event in their calendar unless they change their response in the event invitation email. Furthermore, if more than 200 guests are invited to the event, response status is not propagated to the guests.
selfbooleanOptionalWhether this entry represents the calendar on which this copy of the event appears. Read-only. The default is False.
Default: false

Creates an event — response body — birthday Properties

FieldTypePresenceDescription and constraints
$objectRoot
contactstringOptionalResource name of the contact this birthday event is linked to. This can be used to fetch contact details from People API. Format: "people/c12345". Read-only.
customTypeNamestringOptionalCustom type label specified for this event. This is populated if birthdayProperties.type is set to "custom". Read-only.
typestringOptionalType of birthday or special event. Possible values are:
- "anniversary" - An anniversary other than birthday. Always has a contact.
- "birthday" - A birthday event. This is the default value.
- "custom" - A special date whose label is further specified in the customTypeName field. Always has a contact.
- "other" - A special date which does not fall into the other categories, and does not have a custom label. Always has a contact.
- "self" - Calendar owner's own birthday. Cannot have a contact. The Calendar API only supports creating events with the type "birthday". The type cannot be changed after the event is created.
Default: birthday

Creates an event — response body — conference Data

FieldTypePresenceDescription and constraints
$objectRoot
conferenceIdstringOptionalThe ID of the conference.
Can be used by developers to keep track of conferences, should not be displayed to users.
The ID value is formed differently for each conference solution type:
- eventHangout: ID is not set. (This conference type is deprecated.)
- eventNamedHangout: ID is the name of the Hangout. (This conference type is deprecated.)
- hangoutsMeet: ID is the 10-letter meeting code, for example aaa-bbbb-ccc.
- addOn: ID is defined by the third-party provider. Optional.
conferenceSolutionModelOptionalExpand Creates an event — response body — conference Data conference Solution
The conference solution, such as Google Meet.
Unset for a conference with a failed create request.
Either conferenceSolution and at least one entryPoint, or createRequest is required.
createRequestModelOptionalExpand Creates an event — response body — conference Data create Request
A request to generate a new conference and attach it to the event. The data is generated asynchronously. To see whether the data is present check the status field.
Either conferenceSolution and at least one entryPoint, or createRequest is required.
entryPointsarrayOptionalInformation about individual conference entry points, such as URLs or phone numbers.
All of them must belong to the same conference.
Either conferenceSolution and at least one entryPoint, or createRequest is required.
entryPoints[]ModelEach itemExpand Creates an event — response body — conference Data entry Points item
notesstringOptionalAdditional notes (such as instructions from the domain administrator, legal notices) to display to the user. Can contain HTML. The maximum length is 2048 characters. Optional.
parametersModelOptionalExpand Creates an event — response body — conference Data parameters
Additional properties related to a conference. An example would be a solution-specific setting for enabling video streaming.
signaturestringOptionalThe signature of the conference data.
Generated on server side.
Unset for a conference with a failed create request.
Optional for a conference with a pending create request.

Referenced models: Creates an event — response body — conference Data parameters, Creates an event — response body — conference Data conference Solution, Creates an event — response body — conference Data create Request, Creates an event — response body — conference Data entry Points item

Creates an event — response body — conference Data conference Solution

FieldTypePresenceDescription and constraints
$objectRoot
iconUristringOptionalThe user-visible icon for this solution.
keyModelOptionalExpand Creates an event — response body — conference Data conference Solution key
The key which can uniquely identify the conference solution for this event.
namestringOptionalThe user-visible name of this solution. Not localized.

Referenced models: Creates an event — response body — conference Data conference Solution key

Creates an event — response body — conference Data conference Solution key

FieldTypePresenceDescription and constraints
$objectRoot
typestringOptionalThe conference solution type.
If a client encounters an unfamiliar or empty type, it should still be able to display the entry points. However, it should disallow modifications.
The possible values are:
- "eventHangout" for Hangouts for consumers (deprecated; existing events may show this conference solution type but new conferences cannot be created)
- "eventNamedHangout" for classic Hangouts for Google Workspace users (deprecated; existing events may show this conference solution type but new conferences cannot be created)
- "hangoutsMeet" for Google Meet (http://meet.google.com)
- "addOn" for 3P conference providers

Creates an event — response body — conference Data create Request

FieldTypePresenceDescription and constraints
$objectRoot
conferenceSolutionKeyModelOptionalExpand Creates an event — response body — conference Data conference Solution key
The conference solution, such as Hangouts or Google Meet.
requestIdstringOptionalThe client-generated unique ID for this request.
Clients should regenerate this ID for every new request. If an ID provided is the same as for the previous request, the request is ignored.
statusModelOptionalExpand Creates an event — response body — conference Data create Request status
The status of the conference create request.

Referenced models: Creates an event — response body — conference Data create Request status, Creates an event — response body — conference Data conference Solution key

Creates an event — response body — conference Data create Request status

FieldTypePresenceDescription and constraints
$objectRoot
statusCodestringOptionalThe current status of the conference create request. Read-only.
The possible values are:
- "pending": the conference create request is still being processed.
- "success": the conference create request succeeded, the entry points are populated.
- "failure": the conference create request failed, there are no entry points.

Creates an event — response body — conference Data entry Points item

FieldTypePresenceDescription and constraints
$objectRoot
accessCodestringOptionalThe access code to access the conference. The maximum length is 128 characters.
When creating new conference data, populate only the subset of {meetingCode, accessCode, passcode, password, pin} fields that match the terminology that the conference provider uses. Only the populated fields should be displayed.
Optional.
entryPointFeaturesarrayOptionalFeatures of the entry point, such as being toll or toll-free. One entry point can have multiple features. However, toll and toll-free cannot be both set on the same entry point.
entryPointFeatures[]stringEach item
entryPointTypestringOptionalThe type of the conference entry point.
Possible values are:
- "video" - joining a conference over HTTP. A conference can have zero or one video entry point.
- "phone" - joining a conference by dialing a phone number. A conference can have zero or more phone entry points.
- "sip" - joining a conference over SIP. A conference can have zero or one sip entry point.
- "more" - further conference joining instructions, for example additional phone numbers. A conference can have zero or one more entry point. A conference with only a more entry point is not a valid conference.
labelstringOptionalThe label for the URI. Visible to end users. Not localized. The maximum length is 512 characters.
Examples:
- for video: meet.google.com/aaa-bbbb-ccc
- for phone: +1 123 268 2601
- for sip: 12345678@example.com
- for more: should not be filled
Optional.
meetingCodestringOptionalThe meeting code to access the conference. The maximum length is 128 characters.
When creating new conference data, populate only the subset of {meetingCode, accessCode, passcode, password, pin} fields that match the terminology that the conference provider uses. Only the populated fields should be displayed.
Optional.
passcodestringOptionalThe passcode to access the conference. The maximum length is 128 characters.
When creating new conference data, populate only the subset of {meetingCode, accessCode, passcode, password, pin} fields that match the terminology that the conference provider uses. Only the populated fields should be displayed.
passwordstringOptionalThe password to access the conference. The maximum length is 128 characters.
When creating new conference data, populate only the subset of {meetingCode, accessCode, passcode, password, pin} fields that match the terminology that the conference provider uses. Only the populated fields should be displayed.
Optional.
pinstringOptionalThe PIN to access the conference. The maximum length is 128 characters.
When creating new conference data, populate only the subset of {meetingCode, accessCode, passcode, password, pin} fields that match the terminology that the conference provider uses. Only the populated fields should be displayed.
Optional.
regionCodestringOptionalThe CLDR/ISO 3166 region code for the country associated with this phone access. Example: "SE" for Sweden.
Calendar backend will populate this field only for EntryPointType.PHONE.
uristringOptionalThe URI of the entry point. The maximum length is 1300 characters.
Format:
- for video, http: or https: schema is required.
- for phone, tel: schema is required. The URI should include the entire dial sequence (e.g., tel:+12345678900,,,123456789;1234).
- for sip, sip: schema is required, e.g., sip:12345678@example.com.
- for more, http: or https: schema is required.

Creates an event — response body — conference Data parameters

FieldTypePresenceDescription and constraints
$objectRoot
addOnParametersModelOptionalExpand Creates an event — response body — conference Data parameters add On Parameters
Additional add-on specific data.

Referenced models: Creates an event — response body — conference Data parameters add On Parameters

Creates an event — response body — conference Data parameters add On Parameters

FieldTypePresenceDescription and constraints
$objectRoot
parametersobjectOptionalAdditional keys: see wildcard field
parameters.*stringAdditional keys

Creates an event — response body — creator

FieldTypePresenceDescription and constraints
$objectRootThe creator of the event. Read-only.
displayNamestringOptionalThe creator's name, if available.
emailstringOptionalThe creator's email address, if available.
idstringOptionalThe creator's Profile ID, if available.
selfbooleanOptionalWhether the creator corresponds to the calendar on which this copy of the event appears. Read-only. The default is False.
Default: false

Creates an event — response body — end

FieldTypePresenceDescription and constraints
$objectRoot
datestringOptionalThe date, in the format "yyyy-mm-dd", if this is an all-day event.
Format: date
dateTimestringOptionalThe time, as a combined date-time value (formatted according to RFC3339). A time zone offset is required unless a time zone is explicitly specified in timeZone.
Format: date-time
timeZonestringOptionalThe time zone in which the time is specified. (Formatted as an IANA Time Zone Database name, e.g. "Europe/Zurich".) For recurring events this field is required and specifies the time zone in which the recurrence is expanded. For single events this field is optional and indicates a custom time zone for the event start/end.

Creates an event — response body — extended Properties

FieldTypePresenceDescription and constraints
$objectRootExtended properties of the event.
privateobjectOptionalProperties that are private to the copy of the event that appears on this calendar.
Additional keys: see wildcard field
private.*stringAdditional keysThe name of the private property and the corresponding value.
sharedobjectOptionalProperties that are shared between copies of the event on other attendees' calendars.
Additional keys: see wildcard field
shared.*stringAdditional keysThe name of the shared property and the corresponding value.

Creates an event — response body — focus Time Properties

FieldTypePresenceDescription and constraints
$objectRoot
autoDeclineModestringOptionalWhether to decline meeting invitations which overlap Focus Time events. Valid values are declineNone, meaning that no meeting invitations are declined; declineAllConflictingInvitations, meaning that all conflicting meeting invitations that conflict with the event are declined; and declineOnlyNewConflictingInvitations, meaning that only new conflicting meeting invitations which arrive while the Focus Time event is present are to be declined.
chatStatusstringOptionalThe status to mark the user in Chat and related products. This can be available or doNotDisturb.
declineMessagestringOptionalResponse message to set if an existing event or new invitation is automatically declined by Calendar.

Creates an event — response body — organizer

FieldTypePresenceDescription and constraints
$objectRootThe organizer of the event. If the organizer is also an attendee, this is indicated with a separate entry in attendees with the organizer field set to True. To change the organizer, use the move operation. Read-only, except when importing an event.
displayNamestringOptionalThe organizer's name, if available.
emailstringOptionalThe organizer's email address, if available. It must be a valid email address as per RFC5322.
idstringOptionalThe organizer's Profile ID, if available.
selfbooleanOptionalWhether the organizer corresponds to the calendar on which this copy of the event appears. Read-only. The default is False.
Default: false

Creates an event — response body — out Of Office Properties

FieldTypePresenceDescription and constraints
$objectRoot
autoDeclineModestringOptionalWhether to decline meeting invitations which overlap Out of office events. Valid values are declineNone, meaning that no meeting invitations are declined; declineAllConflictingInvitations, meaning that all conflicting meeting invitations that conflict with the event are declined; and declineOnlyNewConflictingInvitations, meaning that only new conflicting meeting invitations which arrive while the Out of office event is present are to be declined.
declineMessagestringOptionalResponse message to set if an existing event or new invitation is automatically declined by Calendar.

Creates an event — response body — working Location Properties

FieldTypePresenceDescription and constraints
$objectRoot
customLocationobjectOptionalIf present, specifies that the user is working from a custom location.
customLocation.labelstringOptionalAn optional extra label for additional information.
homeOfficeJSONOptionalIf present, specifies that the user is working at home.
officeLocationobjectOptionalIf present, specifies that the user is working from an office.
officeLocation.buildingIdstringOptionalAn optional building identifier. This should reference a building ID in the organization's Resources database.
officeLocation.deskIdstringOptionalAn optional desk identifier.
officeLocation.floorIdstringOptionalAn optional floor identifier.
officeLocation.floorSectionIdstringOptionalAn optional floor section identifier.
officeLocation.labelstringOptionalThe office name that's displayed in Calendar Web and Mobile clients. We recommend you reference a building name in the organization's Resources database.
typestringOptionalType of the working location. Possible values are:
- "homeOffice" - The user is working at home.
- "officeLocation" - The user is working from an office.
- "customLocation" - The user is working from a custom location. Any details are specified in a sub-field of the specified name, but this field may be missing if empty. Any other fields are ignored.
Required when adding working location properties.

Imports an event. This operation is used to add a private copy of an existing event to a calendar. Only events with an eventType of default may be imported.
Deprecated behavior: If a non-default event is imported, its type will be changed to default and any event-type-specific properties it may have will be dropped — request body — body

FieldTypePresenceDescription and constraints
$objectRoot
anyoneCanAddSelfbooleanOptionalWhether anyone can invite themselves to the event (deprecated). Optional. The default is False.
Default: false
attachmentsarrayOptionalFile attachments for the event.
In order to modify attachments the supportsAttachments request parameter should be set to true.
There can be at most 25 attachments per event,
attachments[]ModelEach itemExpand Creates an event — response body — attachments item
attendeesarrayOptionalThe attendees of the event. See the Events with attendees guide for more information on scheduling events with other calendar users. Service accounts need to use domain-wide delegation of authority to populate the attendee list.
attendees[]ModelEach itemExpand Creates an event — request body — body attendees item
attendeesOmittedbooleanOptionalWhether attendees may have been omitted from the event's representation. When retrieving an event, this may be due to a restriction specified by the maxAttendee query parameter. When updating an event, this can be used to only update the participant's response. Optional. The default is False.
Default: false
birthdayPropertiesModelOptionalExpand Creates an event — response body — birthday Properties
Birthday or special event data. Used if eventType is "birthday". Immutable.
colorIdstringOptionalThe color of the event. This is an ID referring to an entry in the event section of the colors definition (see the colors endpoint). Optional.
conferenceDataModelOptionalExpand Creates an event — response body — conference Data
The conference-related information, such as details of a Google Meet conference. To create new conference details use the createRequest field. To persist your changes, remember to set the conferenceDataVersion request parameter to 1 for all event modification requests. Warning: Reusing Google Meet conference data across different events can cause access issues and expose meeting details to unintended users. To help ensure meeting privacy, always generate a unique conference for each event by using the createRequest field.
createdstringOptionalCreation time of the event (as a RFC3339 timestamp). Read-only.
Format: date-time
creatorModelOptionalExpand Creates an event — response body — creator
descriptionstringOptionalDescription of the event. Can contain HTML. Optional.
endModelRequired within parentExpand Creates an event — response body — end
The (exclusive) end time of the event. For a recurring event, this is the end time of the first instance.
endTimeUnspecifiedbooleanOptionalWhether the end time is actually unspecified. An end time is still provided for compatibility reasons, even if this attribute is set to True. The default is False.
Default: false
etagstringOptionalETag of the resource.
eventLabelIdstringOptionalThe ID of the event label assigned to the event. Optional. This refers to the ID of an entry in the labelProperties.eventLabels property of the calendar (see the Calendars.get endpoint.)
This property supersedes the index-based colorId property. To set or change this property, you need to specify eventLabelVersion=1 in the parameters of the insert, import, update, and patch methods.
Setting an empty string, or not setting this field at all, will remove the existing label from the event.
eventTypestringOptionalSpecific type of the event. This cannot be modified after the event is created. Possible values are:
- "birthday" - A special all-day event with an annual recurrence.
- "default" - A regular event or not further specified.
- "focusTime" - A focus-time event.
- "fromGmail" - An event from Gmail. This type of event cannot be created.
- "outOfOffice" - An out-of-office event.
- "workingLocation" - A working location event.
Default: default
extendedPropertiesModelOptionalExpand Creates an event — response body — extended Properties
focusTimePropertiesModelOptionalExpand Creates an event — response body — focus Time Properties
Focus Time event data. Used if eventType is focusTime.
gadgetModelOptionalExpand Creates an event — request body — body gadget
guestsCanInviteOthersbooleanOptionalWhether attendees other than the organizer can invite others to the event. Optional. The default is True.
Default: true
guestsCanModifybooleanOptionalWhether attendees other than the organizer can modify the event. Optional. The default is False.
Default: false
guestsCanSeeOtherGuestsbooleanOptionalWhether attendees other than the organizer can see who the event's attendees are. Optional. The default is True.
Default: true
hangoutLinkstringOptionalAn absolute link to the Google Hangout associated with this event. Read-only.
htmlLinkstringOptionalAn absolute link to this event in the Google Calendar Web UI. Read-only.
iCalUIDstringRequired within parentEvent unique identifier as defined in RFC5545. It is used to uniquely identify events accross calendaring systems and must be supplied when importing events via the import method.
Note that the iCalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same iCalUIDs. To retrieve an event using its iCalUID, call the events.list method using the iCalUID parameter. To retrieve an event using its id, call the events.get method.
idstringOptionalOpaque identifier of the event. When creating new single or recurring events, you can specify their IDs. Provided IDs must follow these rules:
- characters allowed in the ID are those used in base32hex encoding, i.e. lowercase letters a-v and digits 0-9, see section 3.1.2 in RFC2938
- the length of the ID must be between 5 and 1024 characters
- the ID must be unique per calendar Due to the globally distributed nature of the system, we cannot guarantee that ID collisions will be detected at event creation time. To minimize the risk of collisions we recommend using an established UUID algorithm such as one described in RFC4122.
If you do not specify an ID, it will be automatically generated by the server.
Note that the icalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same icalUIDs.
kindstringOptionalType of the resource ("calendar#event").
Default: calendar#event
locationstringOptionalGeographic location of the event as free-form text. Optional.
lockedbooleanOptionalWhether this is a locked event copy where no changes can be made to the main event fields "summary", "description", "location", "start", "end" or "recurrence". The default is False. Read-Only.
Default: false
organizerModelOptionalExpand Creates an event — response body — organizer
originalStartTimeModelOptionalExpand Creates an event — response body — end
For an instance of a recurring event, this is the time at which this event would start according to the recurrence data in the recurring event identified by recurringEventId. It uniquely identifies the instance within the recurring event series even if the instance was moved to a different time. Immutable.
outOfOfficePropertiesModelOptionalExpand Creates an event — response body — out Of Office Properties
Out of office event data. Used if eventType is outOfOffice.
privateCopybooleanOptionalIf set to True, Event propagation is disabled. Note that it is not the same thing as Private event properties. Optional. Immutable. The default is False.
Default: false
recurrencearrayOptionalList of RRULE, EXRULE, RDATE and EXDATE lines for a recurring event, as specified in RFC5545. Note that DTSTART and DTEND lines are not allowed in this field; event start and end times are specified in the start and end fields. This field is omitted for single events or instances of recurring events.
recurrence[]stringEach item
recurringEventIdstringOptionalFor an instance of a recurring event, this is the id of the recurring event to which this instance belongs. Immutable.
remindersModelOptionalExpand Creates an event — request body — body reminders
sequenceintegerOptionalSequence number as per iCalendar.
Format: int32
sourceobjectOptionalSource from which the event was created. For example, a web page, an email message or any document identifiable by an URL with HTTP or HTTPS scheme. Can only be seen or modified by the creator of the event.
source.titlestringOptionalTitle of the source; for example a title of a web page or an email subject.
source.urlstringOptionalURL of the source pointing to a resource. The URL scheme must be HTTP or HTTPS.
startModelRequired within parentExpand Creates an event — response body — end
The (inclusive) start time of the event. For a recurring event, this is the start time of the first instance.
statusstringOptionalStatus of the event. Optional. Possible values are:
- "confirmed" - The event is confirmed. This is the default status.
- "tentative" - The event is tentatively confirmed.
- "cancelled" - The event is cancelled (deleted). The list method returns cancelled events only on incremental sync (when syncToken or updatedMin are specified) or if the showDeleted flag is set to true. The get method always returns them.
A cancelled status represents two different states depending on the event type:
- Cancelled exceptions of an uncancelled recurring event indicate that this instance should no longer be presented to the user. Clients should store these events for the lifetime of the parent recurring event.
Cancelled exceptions are only guaranteed to have values for the id, recurringEventId and originalStartTime fields populated. The other fields might be empty.
- All other cancelled events represent deleted events. Clients should remove their locally synced copies. Such cancelled events will eventually disappear, so do not rely on them being available indefinitely.
Deleted events are only guaranteed to have the id field populated. On the organizer's calendar, cancelled events continue to expose event details (summary, location, etc.) so that they can be restored (undeleted). Similarly, the events to which the user was invited and that they manually removed continue to provide details. However, incremental sync requests with showDeleted set to false will not return these details.
If an event changes its organizer (for example via the move operation) and the original organizer is not on the attendee list, it will leave behind a cancelled event where only the id field is guaranteed to be populated.
summarystringOptionalTitle of the event.
transparencystringOptionalWhether the event blocks time on the calendar. Optional. Possible values are:
- "opaque" - Default value. The event does block time on the calendar. This is equivalent to setting Show me as to Busy in the Calendar UI.
- "transparent" - The event does not block time on the calendar. This is equivalent to setting Show me as to Available in the Calendar UI.
Default: opaque
updatedstringOptionalLast modification time of the main event data (as a RFC3339 timestamp). Updating event reminders will not cause this to change. Read-only.
Format: date-time
visibilitystringOptionalVisibility of the event. Optional. Possible values are:
- "default" - Uses the default visibility for events on the calendar. This is the default value.
- "public" - The event is public and event details are visible to all readers of the calendar.
- "private" - The event is private and only event attendees may view event details.
- "confidential" - The event is private. This value is provided for compatibility reasons.
Note on recurring events: Changing the visibility of a single instance of a recurring event can affect all instances of the series. If the new setting is more restrictive (e.g. from public to private), it is applied to all instances. If the new setting is less restrictive (e.g. from private to public), the change is ignored. To make a recurring event less restrictive, you must update the parent recurring event.
Default: default
workingLocationPropertiesModelOptionalExpand Creates an event — response body — working Location Properties
Working location event data.

Referenced models: Creates an event — response body — conference Data, Creates an event — response body — attachments item, Creates an event — response body — birthday Properties, Creates an event — response body — end, Creates an event — response body — focus Time Properties, Creates an event — response body — out Of Office Properties, Creates an event — response body — working Location Properties, Creates an event — request body — body attendees item, Creates an event — response body — creator, Creates an event — response body — extended Properties, Creates an event — request body — body gadget, Creates an event — response body — organizer, Creates an event — request body — body reminders

Returns events on the specified calendar — response body

FieldTypePresenceDescription and constraints
$objectRoot
accessRolestringOptionalThe user's access role for this calendar. Read-only. Possible values are:
- "none" - The user has no access.
- "freeBusyReader" - The user has read access to free/busy information.
- "reader" - The user has read access to the calendar. Private events will appear to users with reader access, but event details will be hidden.
- "writerWithoutPrivateAccess" - The user has read and write access to the calendar. Private events will appear to users with writerWithoutPrivateAccess access, but event details will be hidden.
- "writer" - The user has read and write access to the calendar. Private events will appear to users with writer access, and event details will be visible.
- "owner" - The user has manager access to the calendar. This role has all of the permissions of the writer role with the additional ability to see and modify access levels of other users.
Important: the owner role is different from the calendar's data owner. A calendar has a single data owner, but can have multiple users with owner role.
defaultRemindersarrayOptionalThe default reminders on the calendar for the authenticated user. These reminders apply to all events on this calendar that do not explicitly override them (i.e. do not have reminders.useDefault set to True).
defaultReminders[]ModelEach itemExpand Returns events on the specified calendar — response body — default Reminders item
descriptionstringOptionalDescription of the calendar. Read-only.
etagstringOptionalETag of the collection.
itemsarrayOptionalList of events on the calendar.
items[]ModelEach itemExpand Creates an event — response body
kindstringOptionalType of the collection ("calendar#events").
Default: calendar#events
nextPageTokenstringOptionalToken used to access the next page of this result. Omitted if no further results are available, in which case nextSyncToken is provided.
nextSyncTokenstringOptionalToken used at a later point in time to retrieve only the entries that have changed since this result was returned. Omitted if further results are available, in which case nextPageToken is provided.
summarystringOptionalTitle of the calendar. Read-only.
timeZonestringOptionalThe time zone of the calendar. Read-only.
updatedstringOptionalLast modification time of the calendar (as a RFC3339 timestamp). Read-only.
Format: date-time

Referenced models: Creates an event — response body, Returns events on the specified calendar — response body — default Reminders item

Returns events on the specified calendar — response body — default Reminders item

FieldTypePresenceDescription and constraints
$objectRoot
methodstringOptionalThe method used by this reminder. Possible values are:
- "email" - Reminders are sent via email.
- "popup" - Reminders are sent via a UI popup.
Required when adding a reminder.
minutesJSONOptional
minutes (anyOf 1)integerAlternativeNumber of minutes before the start of the event when the reminder should trigger. Valid values are between 0 and 40320 (4 weeks in minutes).
Required when adding a reminder.
Format: int32
minutes (anyOf 2)stringAlternativePattern: ^-?[0-9]+(?:\.[0-9]+)?(?:[eE][+-]?[0-9]+)?$

Updates an event This method supports patch semantics — request body — body

FieldTypePresenceDescription and constraints
$objectRoot
anyoneCanAddSelfbooleanOptionalWhether anyone can invite themselves to the event (deprecated). Optional. The default is False.
Default: false
attachmentsarrayOptionalFile attachments for the event.
In order to modify attachments the supportsAttachments request parameter should be set to true.
There can be at most 25 attachments per event,
attachments[]ModelEach itemExpand Creates an event — response body — attachments item
attendeesarrayOptionalThe attendees of the event. See the Events with attendees guide for more information on scheduling events with other calendar users. Service accounts need to use domain-wide delegation of authority to populate the attendee list.
attendees[]ModelEach itemExpand Creates an event — request body — body attendees item
attendeesOmittedbooleanOptionalWhether attendees may have been omitted from the event's representation. When retrieving an event, this may be due to a restriction specified by the maxAttendee query parameter. When updating an event, this can be used to only update the participant's response. Optional. The default is False.
Default: false
birthdayPropertiesModelOptionalExpand Creates an event — response body — birthday Properties
Birthday or special event data. Used if eventType is "birthday". Immutable.
colorIdstringOptionalThe color of the event. This is an ID referring to an entry in the event section of the colors definition (see the colors endpoint). Optional.
conferenceDataModelOptionalExpand Creates an event — response body — conference Data
The conference-related information, such as details of a Google Meet conference. To create new conference details use the createRequest field. To persist your changes, remember to set the conferenceDataVersion request parameter to 1 for all event modification requests. Warning: Reusing Google Meet conference data across different events can cause access issues and expose meeting details to unintended users. To help ensure meeting privacy, always generate a unique conference for each event by using the createRequest field.
createdstringOptionalCreation time of the event (as a RFC3339 timestamp). Read-only.
Format: date-time
creatorModelOptionalExpand Creates an event — response body — creator
descriptionstringOptionalDescription of the event. Can contain HTML. Optional.
endModelOptionalExpand Creates an event — response body — end
The (exclusive) end time of the event. For a recurring event, this is the end time of the first instance.
endTimeUnspecifiedbooleanOptionalWhether the end time is actually unspecified. An end time is still provided for compatibility reasons, even if this attribute is set to True. The default is False.
Default: false
etagstringOptionalETag of the resource.
eventLabelIdstringOptionalThe ID of the event label assigned to the event. Optional. This refers to the ID of an entry in the labelProperties.eventLabels property of the calendar (see the Calendars.get endpoint.)
This property supersedes the index-based colorId property. To set or change this property, you need to specify eventLabelVersion=1 in the parameters of the insert, import, update, and patch methods.
Setting an empty string, or not setting this field at all, will remove the existing label from the event.
eventTypestringOptionalSpecific type of the event. This cannot be modified after the event is created. Possible values are:
- "birthday" - A special all-day event with an annual recurrence.
- "default" - A regular event or not further specified.
- "focusTime" - A focus-time event.
- "fromGmail" - An event from Gmail. This type of event cannot be created.
- "outOfOffice" - An out-of-office event.
- "workingLocation" - A working location event.
Default: default
extendedPropertiesModelOptionalExpand Creates an event — response body — extended Properties
focusTimePropertiesModelOptionalExpand Creates an event — response body — focus Time Properties
Focus Time event data. Used if eventType is focusTime.
gadgetModelOptionalExpand Creates an event — request body — body gadget
guestsCanInviteOthersbooleanOptionalWhether attendees other than the organizer can invite others to the event. Optional. The default is True.
Default: true
guestsCanModifybooleanOptionalWhether attendees other than the organizer can modify the event. Optional. The default is False.
Default: false
guestsCanSeeOtherGuestsbooleanOptionalWhether attendees other than the organizer can see who the event's attendees are. Optional. The default is True.
Default: true
hangoutLinkstringOptionalAn absolute link to the Google Hangout associated with this event. Read-only.
htmlLinkstringOptionalAn absolute link to this event in the Google Calendar Web UI. Read-only.
iCalUIDstringOptionalEvent unique identifier as defined in RFC5545. It is used to uniquely identify events accross calendaring systems and must be supplied when importing events via the import method.
Note that the iCalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same iCalUIDs. To retrieve an event using its iCalUID, call the events.list method using the iCalUID parameter. To retrieve an event using its id, call the events.get method.
idstringOptionalOpaque identifier of the event. When creating new single or recurring events, you can specify their IDs. Provided IDs must follow these rules:
- characters allowed in the ID are those used in base32hex encoding, i.e. lowercase letters a-v and digits 0-9, see section 3.1.2 in RFC2938
- the length of the ID must be between 5 and 1024 characters
- the ID must be unique per calendar Due to the globally distributed nature of the system, we cannot guarantee that ID collisions will be detected at event creation time. To minimize the risk of collisions we recommend using an established UUID algorithm such as one described in RFC4122.
If you do not specify an ID, it will be automatically generated by the server.
Note that the icalUID and the id are not identical and only one of them should be supplied at event creation time. One difference in their semantics is that in recurring events, all occurrences of one event have different ids while they all share the same icalUIDs.
kindstringOptionalType of the resource ("calendar#event").
Default: calendar#event
locationstringOptionalGeographic location of the event as free-form text. Optional.
lockedbooleanOptionalWhether this is a locked event copy where no changes can be made to the main event fields "summary", "description", "location", "start", "end" or "recurrence". The default is False. Read-Only.
Default: false
organizerModelOptionalExpand Creates an event — response body — organizer
originalStartTimeModelOptionalExpand Creates an event — response body — end
For an instance of a recurring event, this is the time at which this event would start according to the recurrence data in the recurring event identified by recurringEventId. It uniquely identifies the instance within the recurring event series even if the instance was moved to a different time. Immutable.
outOfOfficePropertiesModelOptionalExpand Creates an event — response body — out Of Office Properties
Out of office event data. Used if eventType is outOfOffice.
privateCopybooleanOptionalIf set to True, Event propagation is disabled. Note that it is not the same thing as Private event properties. Optional. Immutable. The default is False.
Default: false
recurrencearrayOptionalList of RRULE, EXRULE, RDATE and EXDATE lines for a recurring event, as specified in RFC5545. Note that DTSTART and DTEND lines are not allowed in this field; event start and end times are specified in the start and end fields. This field is omitted for single events or instances of recurring events.
recurrence[]stringEach item
recurringEventIdstringOptionalFor an instance of a recurring event, this is the id of the recurring event to which this instance belongs. Immutable.
remindersModelOptionalExpand Creates an event — request body — body reminders
sequenceintegerOptionalSequence number as per iCalendar.
Format: int32
sourceobjectOptionalSource from which the event was created. For example, a web page, an email message or any document identifiable by an URL with HTTP or HTTPS scheme. Can only be seen or modified by the creator of the event.
source.titlestringOptionalTitle of the source; for example a title of a web page or an email subject.
source.urlstringOptionalURL of the source pointing to a resource. The URL scheme must be HTTP or HTTPS.
startModelOptionalExpand Creates an event — response body — end
The (inclusive) start time of the event. For a recurring event, this is the start time of the first instance.
statusstringOptionalStatus of the event. Optional. Possible values are:
- "confirmed" - The event is confirmed. This is the default status.
- "tentative" - The event is tentatively confirmed.
- "cancelled" - The event is cancelled (deleted). The list method returns cancelled events only on incremental sync (when syncToken or updatedMin are specified) or if the showDeleted flag is set to true. The get method always returns them.
A cancelled status represents two different states depending on the event type:
- Cancelled exceptions of an uncancelled recurring event indicate that this instance should no longer be presented to the user. Clients should store these events for the lifetime of the parent recurring event.
Cancelled exceptions are only guaranteed to have values for the id, recurringEventId and originalStartTime fields populated. The other fields might be empty.
- All other cancelled events represent deleted events. Clients should remove their locally synced copies. Such cancelled events will eventually disappear, so do not rely on them being available indefinitely.
Deleted events are only guaranteed to have the id field populated. On the organizer's calendar, cancelled events continue to expose event details (summary, location, etc.) so that they can be restored (undeleted). Similarly, the events to which the user was invited and that they manually removed continue to provide details. However, incremental sync requests with showDeleted set to false will not return these details.
If an event changes its organizer (for example via the move operation) and the original organizer is not on the attendee list, it will leave behind a cancelled event where only the id field is guaranteed to be populated.
summarystringOptionalTitle of the event.
transparencystringOptionalWhether the event blocks time on the calendar. Optional. Possible values are:
- "opaque" - Default value. The event does block time on the calendar. This is equivalent to setting Show me as to Busy in the Calendar UI.
- "transparent" - The event does not block time on the calendar. This is equivalent to setting Show me as to Available in the Calendar UI.
Default: opaque
updatedstringOptionalLast modification time of the main event data (as a RFC3339 timestamp). Updating event reminders will not cause this to change. Read-only.
Format: date-time
visibilitystringOptionalVisibility of the event. Optional. Possible values are:
- "default" - Uses the default visibility for events on the calendar. This is the default value.
- "public" - The event is public and event details are visible to all readers of the calendar.
- "private" - The event is private and only event attendees may view event details.
- "confidential" - The event is private. This value is provided for compatibility reasons.
Note on recurring events: Changing the visibility of a single instance of a recurring event can affect all instances of the series. If the new setting is more restrictive (e.g. from public to private), it is applied to all instances. If the new setting is less restrictive (e.g. from private to public), the change is ignored. To make a recurring event less restrictive, you must update the parent recurring event.
Default: default
workingLocationPropertiesModelOptionalExpand Creates an event — response body — working Location Properties
Working location event data.

Referenced models: Creates an event — response body — conference Data, Creates an event — response body — attachments item, Creates an event — response body — birthday Properties, Creates an event — response body — end, Creates an event — response body — focus Time Properties, Creates an event — response body — out Of Office Properties, Creates an event — response body — working Location Properties, Creates an event — request body — body attendees item, Creates an event — response body — creator, Creates an event — response body — extended Properties, Creates an event — request body — body gadget, Creates an event — response body — organizer, Creates an event — request body — body reminders

Updates an event — request body — query

FieldTypePresenceDescription and constraints
$objectRootAdditional keys: not allowed
fieldsstringOptionalSelector specifying which fields to include in a partial response.
prettyPrintbooleanOptionalReturns response with indentations and line breaks.
Default: true
quotaUserstringOptionalAn opaque string that represents a user for quota purposes. Must not exceed 40 characters.
userIpstringOptionalDeprecated. Please use quotaUser instead.
alwaysIncludeEmailbooleanOptionalDeprecated and ignored. A value will always be returned in the email field for the organizer, creator and attendees, even if no real email address is available (i.e. a generated, non-working value will be provided).
conferenceDataVersionintegerOptionalVersion number of conference data supported by the API client. Version 0 assumes no conference data support and ignores conference data in the event's body. Version 1 enables support for copying of ConferenceData as well as for creating new conferences using the createRequest field of conferenceData. The default is 0.
Format: int32
Maximum: 1
Minimum: 0
eventLabelVersionintegerOptionalVersion number of the event label feature supported by the API client. Version 0 assumes no event label support and processes the colorId field for color management. Version 1 enables support for event labels, and processes the eventLabelId in the event's body. In this case, the colorId field is ignored. The default is 0.
Format: int32
Maximum: 1
Minimum: 0
maxAttendeesintegerOptionalThe maximum number of attendees to include in the response. If there are more than the specified number of attendees, only the participant is returned. Optional.
Format: int32
Minimum: 1
sendNotificationsbooleanOptionalDeprecated. Please use sendUpdates instead.

Whether to send notifications about the event update (for example, description changes, etc.). Note that some emails might still be sent even if you set the value to false. The default is false.
sendUpdatesstringOptionalGuests who should receive notifications about the event update (for example, title changes, etc.).
One of: all, externalOnly, none
supportsAttachmentsbooleanOptionalWhether API client performing operation supports event attachments. Optional. The default is False.

Watch for changes to Events resources — request body — query

FieldTypePresenceDescription and constraints
$objectRootAdditional keys: not allowed
fieldsstringOptionalSelector specifying which fields to include in a partial response.
prettyPrintbooleanOptionalReturns response with indentations and line breaks.
Default: true
quotaUserstringOptionalAn opaque string that represents a user for quota purposes. Must not exceed 40 characters.
userIpstringOptionalDeprecated. Please use quotaUser instead.
alwaysIncludeEmailbooleanOptionalDeprecated and ignored.
eventTypesarrayOptional
eventTypes[]stringEach itemEvent types to return. Optional. This parameter can be repeated multiple times to return events of different types. If unset, returns all event types.
One of: birthday, default, focusTime, fromGmail, outOfOffice, workingLocation
iCalUIDstringOptionalSpecifies an event ID in the iCalendar format to be provided in the response. Optional. Use this if you want to search for an event by its iCalendar ID.
maxAttendeesintegerOptionalThe maximum number of attendees to include in the response. If there are more than the specified number of attendees, only the participant is returned. Optional.
Format: int32
Minimum: 1
maxResultsintegerOptionalMaximum number of events returned on one result page. The number of events in the resulting page may be less than this value, or none at all, even if there are more events matching the query. Incomplete pages can be detected by a non-empty nextPageToken field in the response. By default the value is 250 events. The page size can never be larger than 2500 events. Optional.
Default: 250
Format: int32
Minimum: 1
orderBystringOptionalThe order of the events returned in the result. Optional. The default is an unspecified, stable order.
One of: startTime, updated
pageTokenstringOptionalToken specifying which result page to return. Optional.
privateExtendedPropertyarrayOptional
privateExtendedProperty[]stringEach itemExtended properties constraint specified as propertyName=value. Matches only private properties. This parameter might be repeated multiple times to return events that match all given constraints.
qstringOptionalFree text search terms to find events that match these terms in the following fields:

- summary
- description
- location
- attendee's displayName
- attendee's email
- organizer's displayName
- organizer's email
- workingLocationProperties.officeLocation.buildingId
- workingLocationProperties.officeLocation.deskId
- workingLocationProperties.officeLocation.label
- workingLocationProperties.customLocation.label
These search terms also match predefined keywords against all display title translations of working location, out-of-office, and focus-time events. For example, searching for "Office" or "Bureau" returns working location events of type officeLocation, whereas searching for "Out of office" or "Abwesend" returns out-of-office events. Optional.
sharedExtendedPropertyarrayOptional
sharedExtendedProperty[]stringEach itemExtended properties constraint specified as propertyName=value. Matches only shared properties. This parameter might be repeated multiple times to return events that match all given constraints.
showDeletedbooleanOptionalWhether to include deleted events (with status equals "cancelled") in the result. Cancelled instances of recurring events (but not the underlying recurring event) will still be included if showDeleted and singleEvents are both False. If showDeleted and singleEvents are both True, only single instances of deleted events (but not the underlying recurring events) are returned. Optional. The default is False.
showHiddenInvitationsbooleanOptionalWhether to include hidden invitations in the result. Optional. The default is False.
singleEventsbooleanOptionalWhether to expand recurring events into instances and only return single one-off events and instances of recurring events, but not the underlying recurring events themselves. Optional. The default is False.
syncTokenstringOptionalToken obtained from the nextSyncToken field returned on the last page of results from the previous list request. It makes the result of this list request contain only entries that have changed since then. All events deleted since the previous list request will always be in the result set and it is not allowed to set showDeleted to False.
There are several query parameters that cannot be specified together with nextSyncToken to ensure consistency of the client state.

These are:
- iCalUID
- orderBy
- privateExtendedProperty
- q
- sharedExtendedProperty
- timeMin
- timeMax
- updatedMin All other query parameters should be the same as for the initial synchronization to avoid undefined behavior. If the syncToken expires, the server will respond with a 410 GONE response code and the client should clear its storage and perform a full synchronization without any syncToken.
Learn more about incremental synchronization.
Optional. The default is to return all entries.
timeMaxstringOptionalUpper bound (exclusive) for an event's start time to filter by. Optional. The default is not to filter by start time. Must be an RFC3339 timestamp with mandatory time zone offset, for example, 2011-06-03T10:00:00-07:00, 2011-06-03T10:00:00Z. Milliseconds may be provided but are ignored. If timeMin is set, timeMax must be greater than timeMin.
Format: date-time
timeMinstringOptionalLower bound (exclusive) for an event's end time to filter by. Optional. The default is not to filter by end time. Must be an RFC3339 timestamp with mandatory time zone offset, for example, 2011-06-03T10:00:00-07:00, 2011-06-03T10:00:00Z. Milliseconds may be provided but are ignored. If timeMax is set, timeMin must be smaller than timeMax.
Format: date-time
timeZonestringOptionalTime zone used in the response. Optional. The default is the time zone of the calendar.
updatedMinstringOptionalLower bound for an event's last modification time (as a RFC3339 timestamp) to filter by. When specified, entries deleted since this time will always be included regardless of showDeleted. Optional. The default is not to filter by last modification time.
Format: date-time

Report an issue with this page

Necessary

Required for sign-in, security, authorization, and remembering your choices.

Always active

Analytics

Helps us understand which product and documentation features are useful.

Performance diagnostics

Uses performance tracing and privacy-masked session replay to diagnose problems.

You can change these choices at any time from Cookie settings.